Could not find a version that satisfies the requirement evaluate

Here they say the Evaluate library has to be installed in a virtual environment. So I follow this guide and I create and activate a virtual environment doing:

python3 -m venv env

and

source env/bin/activate

Then when I try to install the evaluate package

python3 -m pip install requests

This happens:

(env) bscuser@localhost:~> python3 -m pip install evaluate
ERROR: Could not find a version that satisfies the requirement evaluate (from versions: none)
ERROR: No matching distribution found for evaluate

How can I solve this?

I’m using OpenSuse Leap 15.3 and my Python version is 3.6.15.

>Solution :

Look at the left side-bar on PyPi package page for evaluate. Near the bottom is the "Programming Language" section. It lists availability for Python version 3.7 to 3.10.

You will need to create a new environment with one of those versions of Python.

Leave a Reply