Using preview package of hydrated_bloc

I want to use the 9.0.0-dev version of the hydrated_bloc package.

If I run pub get on my pubspec.yaml:

dependencies:
  flutter:
    sdk: flutter
  hydrated_bloc: ^9.0.0-dev.3

I get the message Latest available version is: 8.1.0

How can I get the prereleases?

>Solution :

That is the version found on pud.dev.
If you want to use the latest dev package you could point to the github repo instead

hydrated_bloc:
    git:
      url: https://github.com/felangel/bloc.git
      ref: master
      path: packages/hydrated_bloc/

Leave a Reply